FB117E2: Platform instability impacting Web console performance

Incident Report for Fireblocks Europe2

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:26 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 20:25 UTC

Update

Console and mobile signing performance remains degraded at this time, please refresh the page in case you are experiencing slowness during navigation.

Please monitor the Google Firestore status here:
https://status.firebase.google.com/incidents/nEaBHaPRDXMKAsq9sp7G
Posted Jun 12, 2025 - 19:41 UTC

Update

Console performance remains degraded at this time, please refresh the page in case you are experiencing slowness during navigation.

Please monitor the google Firestore status here:
https://status.firebase.google.com/incidents/nEaBHaPRDXMKAsq9sp7G
Posted Jun 12, 2025 - 19:36 UTC

Monitoring

Console performance remains degraded at this time, please refresh the page in case you are experiencing slowness during navigation.

Please monitor the google Firestore status here:
https://status.firebase.google.com/incidents/nEaBHaPRDXMKAsq9sp7G
Posted Jun 12, 2025 - 18:57 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 18:57 UTC

Identified

We have identified the issue relates directly to an outage with Google cloud processing
https://status.firebase.google.com/incidents/nEaBHaPRDXMKAsq9sp7G
Posted Jun 12, 2025 - 18:28 UTC

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 18:24 UTC
This incident affected: Web console, Fireblocks mobile app, and Transactions engine.