FB109E2: Blockchain Binance Smart chain is undergoing maintenance
Incident Report for Fireblocks Europe2
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 04:34 UTC
Identified
Binance smartchain is undergoing maintenance currently. During this period, the network might be disrupted from time to time. Fireblocks will resume once the Blockchain is back roughly by 4:30 UTC.
Posted Nov 10, 2023 - 03:13 UTC
This incident affected: Blockchain nodes (Binance Smart Chain).